Results 1 to 2 of 2
  1. #1

    I can't launch my League of Legends

    Like I stated in the topic, I clicked my LoL icon and it won't launch.
    Then i tried 'run as administrator' still didn't work.
    Then i tried click once and hold enter button for a long long period of time but that still didn't work..

    So what is the problem? Please help.. I have a fixed match with my friends tonight and I want to owned them

    Thanks very much,
    IGN : x7Oh
    Reply With Quote
    Rate +Rate -

  2. #2
    Senior Member Accepted the Summoner's Code JokerPrince95's Avatar
    Join Date
    Jun 2011
    Posts
    1,569
    Try check whether ur shortcut is linked to the file itself.the system could hv accidentally changed the file directory etc.If nt den mayb reinstall or u can try searching for ur lol folder and click on the program icon itself instead of the shortcut
    IGN:Scorpion
    Reply With Quote
    Rate +Rate -

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •